Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

PHP Newsletter Software/Script und E-Mail-Marketing Software SuperWebMailer

Moderator: mirko

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 21.10.2019, 09:28

Oh man - das wars!
Im Responder habe ich jetzt "Versenden ab 07 Uhr morgens" eingestellt.
Und jetzt klappt es. :)

Danke :)

Benutzeravatar
mirko
Beiträge: 21669
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von mirko » 18.10.2019, 13:14

Die Ausführung der Aufgabe nur einmal am Tag wird das Problem sein. War die letzte Ausführung z.B. heute 8:55 Uhr aber beim Geburtstags-Responder ist angegeben nach 9 Uhr erst versenden, dann schickt er heute nichts und die nächsten Tage auch nichts, denn er wird bei Ausführung 1x am Tag immer 8:55 Uhr die Aufgabe ausführen, es ist nicht um 9, also schickt er nichts.

Meine Empfehlung 1x pro Stunde oder alle 2 Stunden die Geburtstags-Responder prüfen lassen.

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 18.10.2019, 08:51

Zweites Bild fehlte...
2019-10-18 08_29_36-Window.png
2019-10-18 08_29_36-Window.png (33.77 KiB) 630 mal betrachtet

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 18.10.2019, 08:50

Heute war das laufende Mailing durch und wir konnten den Webserver einmal neustarten. Hat leider nichts gebracht.
Hier nochmal aktuelle Screenshots - trotzdem dass Geburtstage vorhanden sind, behauptet der Responder es wäre nichts zum Versenden da.

Auffällig ist, dass dieser "Abbruch" nach dem 10.10. stattfand. An dem Tag wollte ich den Versand der Mails weiter nach vorne verlegen und habe daher gegen 09:00 Uhr einmal den Versand kurz auf "Alle 5 Minuten" geändert und die Aufgaben mit Klick auf "Etwaige Aufgaben jetzt ausführen" gestartet. Danach habe ich den Versand wieder auf "1 mal am Tag" gesetzt.

Seitdem geht es nicht mehr.

Der Dateianhang 2019-10-18 08_28_56-Window.png existiert nicht mehr.
Dateianhänge
2019-10-18 08_28_56-Window.png
2019-10-18 08_28_56-Window.png (17.79 KiB) 630 mal betrachtet

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 17.10.2019, 09:32

Ja, es hatten die ganzen Tage über Leute Geburtstag.
Nein, sie stehen nicht im Versandprotokoll - so prüfe ich das ja dann immer, ob die Mails rausgingen.

Benutzeravatar
mirko
Beiträge: 21669
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von mirko » 16.10.2019, 16:55

Na haben den Empfänger heute Geburtstag? Stehen die Empfänger-E-Mail-Adressen im Versandprotokoll des Geburtstags-Responders?

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 16.10.2019, 16:01

Danach scheint es, dass er den Dienst ausgeführt hat.
Aber die Mails sind nicht rausgegangen.
Wie gesagt, die Geburtstags-Mails gingen das letzte Mal am 10.10. raus.

Sollen wir vielleicht einfach mal den Webserver neustarten?
Würde das was bringen?

Benutzeravatar
mirko
Beiträge: 21669
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von mirko » 16.10.2019, 15:49

ist er danach durchgelaufen? Kann auch mal sein, dass der Webserver-Dienst neu gestartet wurde, dann bricht natürlich sofort das Script ab, beim nächsten Mal führt er die Aufgabe neu aus bzw. versendet dann noch die E-Mails. Wenn der Webserver-Dienst mal neu gestartet wird, kann es im ungünstigsten Fall zum Doppelversand kommen, das aber nur wenn nicht InnoDB für die Datenbank verwendet wird.

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 16.10.2019, 13:09

Das hier ist der Job von heute morgen (siehe Bild), der eigentlich ein paar Mails hätte raushauen müssen.
Momentan läuft ein "normales" Mailing, die Mails gehen raus.
2019-10-16 12_49_15-Window.png
2019-10-16 12_49_15-Window.png (34.04 KiB) 651 mal betrachtet

Benutzeravatar
mirko
Beiträge: 21669
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von mirko » 16.10.2019, 11:55

Das Script ist abgebrochen (worden). Er wird dann 30 Minuten warten, dann die .lock-Datei löschen und nochmals den E-Mail-Versand oder andere Aufgabe probieren. Bricht es wieder ab, gibt es eine neue .lock-Datei. Unter Menü Einstellungen - Ereignisprotokoll anschauen, ob es abgebrochene Aufgaben gibt (Sanduhrsymbol). Tja und dann kommt es halt drauf an, was für eine Aufgabe es ist.

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 16.10.2019, 10:06

Hallo,

das Problem ist wieder da. Am 10.10. wurden zuletzt Geburtstags-Mails versendet.
Ich habe mal den Scriptaufruf wie unten beschrieben gemacht und erhalte diese Meldung:

CronJob lock by file /srv/www/news.ntbwelt.de/supermailer/SuperWebMailer.lock active, try again later.

Was bedeutet das? Was kann ich tun?

Grüße,
Sikue

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 29.01.2019, 09:13

Hallo,

das ist jetzt echt strange.
Nach dem Einspielen des Updates läuft es nun wieder.
Es gehen wieder Mails raus.

Woran es gelegen hat - keine Ahnung.

Grüße,
Sikue

Benutzeravatar
mirko
Beiträge: 21669
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von mirko » 25.01.2019, 16:01

Geht nur testen, am Geburtstags-Responder selbst ist nichts verändert.

sikue
Beiträge: 96
Registriert: 31.08.2009, 12:06

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von sikue » 25.01.2019, 14:11

Hallo,

sorry, ich war sehr eingespannt und dann liefen dauernd Mailings, da wollte ich das nicht machen.
Heute kam ich dann dazu :)

Es kommt keine Fehlermeldung, was ja eigentlich gut ist....
Nur erklärt es nicht, wieso nicht gesendet wird. Hm.

Ich stelle jetzt den Responder wieder ein.
Heute habe ich auch das Update eingespielt, welches Montag rauskam. Vielleicht ändert das was?

Grüße,
Sikue

Benutzeravatar
mirko
Beiträge: 21669
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Geburstags-Responder - sendet er? Sendet er nicht? Oder sendet er am falschen Tag?

Beitrag von mirko » 16.01.2019, 11:11

Nein habe nichts bekommen, das auf einen Geburtstag hindeutet, nur Spam und Dating-Angebote. :D

Zur Fehlersuche geht nur:

den automatischen Aufruf des CronJob-Scripts vorübergehend deaktivieren

unter Menü Einstellungen - Geplante Aufgaben die Prüfung der Geburtstags-Responder auf 1 Minute einstellen und speichern

im Browser manuell das CronJob-Script mit Parametern ?language=de&DEBUG=1 aufrufen, z.B. http(s)://meineseite.de/swm/crons.php?language=de&DEBUG=1

schauen ob Fehlermeldungen entweder vom PHP oder von SQL-Anweisungen ausgegeben werden, das ganze ein paar Mal 1x pro Minute ausführen

Antworten