Fehlermeldung nach Update

Probleme, Tipps & Tricks zu LANMailServer

Moderator: mirko

Antworten
WinAdmin
Beiträge: 6
Registriert: 29.07.2019, 19:43

Re: Fehlermeldung nach Update

Beitrag von WinAdmin » 02.10.2021, 19:56

Programm läuft wieder, vielen Dank für die zügige Bearbeitung!

Gruß

Oelfinger
Beiträge: 2
Registriert: 25.09.2021, 14:14

Re: Fehlermeldung nach Update

Beitrag von Oelfinger » 28.09.2021, 04:52

Danke für die schnelle Bereitstellung.
Ich werde erst zum Ende der Woche testen können und gebe dann auch gerne Feedback.

Benutzeravatar
mirko
Beiträge: 22326
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Fehlermeldung nach Update

Beitrag von mirko » 27.09.2021, 22:27

Update ist seit heute Mittag online. Falls die Version 5.20 nicht mehr startet, dann manuell das Update einspielen.

Richtig Version laden 32bit oder 64bit https://www.lanmailserver.de/download.htm

ZIP-Datei in einen neuen Ordner auspacken, danach die Dateien LANMailServer.ex_ in LANMailServer.exe und LMNTService.ex_ in LMNTService.exe umbenennen, danach beide Dateien in den LANMailServer-Programmordner kopieren, zuvor den Dienst und LANMailServer Console beenden.

Benutzeravatar
mirko
Beiträge: 22326
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Fehlermeldung nach Update

Beitrag von mirko » 25.09.2021, 17:59

Gibt es Anfang nächster Woche ein Update, dann funktioniert das wieder korrekt.

Oelfinger
Beiträge: 2
Registriert: 25.09.2021, 14:14

Re: Fehlermeldung nach Update

Beitrag von Oelfinger » 25.09.2021, 14:54

Hallo,

ich habe nach dem Update genau das gleiche Fehlerbild. Auch eine erneute Installation der neuen Version konnte das zuvor von den Anderen bereits beschriebene Fehlerbild nicht beseitigen.

In der LOG-Datei gab es keine Ausgaben zu Fehler:

//Vor dem Update
25.09.2021 13:31:00 - Zugriff auf den IMAP4-Server durch: 192.168.0.10 (SSL encrypted)
25.09.2021 13:31:01 - 192.168.0.10 hat die Verbindung zum IMAP4-Server beendet.

//Beenden des Dienstes zum ausführen des Updates
25.09.2021 13:47:21 - LANMailServer Console gestartet.
25.09.2021 13:48:26 - LANMailServer Service Dienste werden beendet...
25.09.2021 13:49:22 - LANMailServer Console beendet.

//Keine Ausgaben im LOG nach dem Update während des Fehlers

//Nach dem Downgrade auf die Version 5.12
25.09.2021 14:21:35 - LANMailServer wird initialisiert.
25.09.2021 14:21:35 - Prüfe nicht bearbeitete E-Mails in C:\ProgramData\LANMailServer\Data\Processing\...
25.09.2021 14:21:35 - Prüfung erfolgreich abgeschlossen.
25.09.2021 14:21:35 - LANMailServer Verbindungsüberwachung aktiv.
25.09.2021 14:21:35 - LANMailServer Service Dienste werden gestartet...
25.09.2021 14:21:35 - Versuche SMTP-Server zu starten...
25.09.2021 14:21:37 - LANMailServer Console gestartet.
25.09.2021 14:21:38 - SMTP-Server erfolgreich gestartet.
25.09.2021 14:21:38 - Versuche POP3-Server zu starten...
25.09.2021 14:21:38 - POP3-Server erfolgreich gestartet.
25.09.2021 14:21:38 - Versuche IMAP4-Server zu starten...
25.09.2021 14:21:38 - IMAP4-Server erfolgreich gestartet.
....

Der Dienst selber war zum Fehlerzeitpunkt für die Clients nicht erreichbar, und das Starten der LanMailServer Console wurde mit der Fehlermeldung: "Fehler beim Zugriff auf die Datenbank, Variante des Typs (OleStr) konnte nicht in Typ (Double) konvertiert werden" abgebrochen.



FYI (Workaroud bis zum FIX):
Nachdem ich das Update nochmals deinstalliert habe und ein Downgrade zurück zur vorherigen Version (5.12) durchgeführt habe, läuft alles sofort wieder wie gewohnt.

WinAdmin
Beiträge: 6
Registriert: 29.07.2019, 19:43

Re: Fehlermeldung nach Update

Beitrag von WinAdmin » 25.09.2021, 08:34

Der Fehler erscheint direkt beim Starten beider Programme als Fenster.
Es lässt sich nichts mehr Öffnen, nichts auslesen, etc...

Gruß

Benutzeravatar
mirko
Beiträge: 22326
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Fehlermeldung nach Update

Beitrag von mirko » 24.09.2021, 21:35

Wird ein Fehlerreport ausgegeben? Wenn nicht, bei was tritt das auf?

WinAdmin
Beiträge: 6
Registriert: 29.07.2019, 19:43

Fehlermeldung nach Update

Beitrag von WinAdmin » 24.09.2021, 21:30

Hallo,

nach dem letzten Update erhalte ich in der Console sowie beim LANMailServer selber
folgende Fehlermeldung: "Fehler beim Zugriff auf die Datenbank, Variante des Typs (OleStr)
konnte nicht in Typ (Double) konvertiert werden"
Wer weiß Rat?

Danke und Gruß!

Antworten