Probleme mit Unterseite seit letztem Update

PHP Newsletter Software/Script und E-Mail-Marketing Software SuperWebMailer

Moderator: mirko

Benutzeravatar
mirko
Beiträge: 22519
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Probleme mit Unterseite seit letztem Update

Beitrag von mirko » 21.09.2022, 22:20

Nein keine Nachteile, ganz im Gegenteil, bei Fehlern, bekommt man eine ordentliche Fehlermeldung. Bei PHP mail() gibt es nur "versendet" oder "nicht versendet", keinen Fehlertext dazu.

Meerengel
Beiträge: 20
Registriert: 14.09.2018, 18:07

Re: Probleme mit Unterseite seit letztem Update

Beitrag von Meerengel » 21.09.2022, 19:18

Danke Mirko! Mit der geänderten Versandvariante klappt es. Gibt es da irgendwelche Nachteile ? Oder kann ich das problemlos dauerhaft benutzen.

Benutzeravatar
mirko
Beiträge: 22519
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Probleme mit Unterseite seit letztem Update

Beitrag von mirko » 20.09.2022, 22:21

Mail-Header ist defekt, das liegt an Hosteurope, die haben am E-Mail-Server etwas geändert. Der Zeilenumbruch muss auf CRLF geändert werden, LF, normalerweise für Unix-Systeme, funktioniert nicht. Alternativ Menü Einstellungen - Versandvariante eine neue Versandvariante über SMTP-Server anlegen, Servername und Benutzername/Passwort angeben, beim E-Mailing diese Variante wählen.

Meerengel
Beiträge: 20
Registriert: 14.09.2018, 18:07

Re: Probleme mit Unterseite seit letztem Update

Beitrag von Meerengel » 20.09.2022, 21:51

Mail ist versendet. Habe mehrere Mailarten ausprobiert. auch ausschließlich Text. Dasselbe Ergebnis. Danke dir für deine Hilfe!

Benutzeravatar
mirko
Beiträge: 22519
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Probleme mit Unterseite seit letztem Update

Beitrag von mirko » 20.09.2022, 18:55

Ist im Header der E-Mail ein Fehler. Mir mal an info@<programmname>.de (für <programmname> SuperWebMailer) mit SuperWebMailer ein Test-E-Mail zusenden, vorher natürlich testen, ob die wirklich nicht korrekt ist.

Meerengel
Beiträge: 20
Registriert: 14.09.2018, 18:07

Re: Probleme mit Unterseite seit letztem Update

Beitrag von Meerengel » 20.09.2022, 18:46

Danke dir. Zeilenumbruch stand auf automatisch. Alle 3 Varianten bringen keine Veränderung. Was kann ich noch probieren?

Benutzeravatar
mirko
Beiträge: 22519
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Probleme mit Unterseite seit letztem Update

Beitrag von mirko » 19.09.2022, 15:40

Menü Einstellungen - Optionen, Zeilenumbruch auf "Automatisch" stellen, falls nicht eingestellt, CRLF oder LF probieren.

Meerengel
Beiträge: 20
Registriert: 14.09.2018, 18:07

Re: Probleme mit Unterseite seit letztem Update

Beitrag von Meerengel » 19.09.2022, 15:10

O.k. Danke. Da sowohl mein Webdesigner als auch ich ratlos sind, hat er einfach nochmal das Update eingespielt. In PHP 7.4 läuft nach wie vor alles normal. PHP 8.1 kann ich jetzt alles aufrufen, Mail erstellen, versenden, usw. alles wie gewohnt. Allerdings erscheint die Mail im Posteingang in folgender Form:

This is a multi-part message in MIME format.

------=_NextPart_000_7D83_8598D540.54021FE7
Content-Type: multipart/alternative;
boundary="----=_NextPart_001_7D83_8598D540.54021FE7"

------=_NextPart_001_7D83_8598D540.54021FE7
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset="utf-8"

Testmail!!

Neuer Intensivkurs im November:
"Es ist sicher, mich sicher zu f=C3=BChlen!"
Gedankenkarussell, Hyperwachsamkeit und Angst, dass etwas schlimmes passier=
t ablegen, Inneren Frieden, Gelassenheit und Flow erleben
Urvertrauen-Intensivkurs vom 14.11. - 21.11.18 am Telefon
Liebe/r ,
Es geht in den Endspurt. Heute haben die Engel unsere Energiek=C3=B6rper un=
d jede einzelne Zelle gesp=C3=BClt, so dass alles, was sich im Verlauf der =
letzten Woche angel=C3=B6st hat, auch wirklich herausgel=C3=B6st wurde. Die=
Transformationsengel haben deine Masterzelle mit hochpotenter Transformati=
onsenergie behandelt und diese von alten =C3=9Cberzeugungen und Impr=C3=A4g=
nierungen gereinigt. Deine Masterzelle ist deine Ursprungszelle, aus der al=
le weiteren Zellen entsprungen sind und entspringen. Die Engel haben dich m=
it der genau der Energie verbunden, die du jetzt brauchst, um weiter zu kom=
men in deinem Prozess des Vertrauens. Die Glaubenss=C3=A4tze, mit denen du =
dabei verbunden wurdest, sehen bei uns teilweise etwas unterschiedlich aus,=
je nachdem, was jetzt f=C3=BCr dich wichtig ist, um dich sicher zu f=C3=BC=
hlen und loslassen zu k=C3=B6nnen.=20

usw.

Vielleicht kannst du uns jetzt helfen?
Vielen Dank schonmal.

Benutzeravatar
mirko
Beiträge: 22519
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Probleme mit Unterseite seit letztem Update

Beitrag von mirko » 16.09.2022, 14:31

Nichts erkennt man, das sind alles keine Scripte vom SuperWebMailer, sondern eure eigenen, die nicht existieren.

Meerengel
Beiträge: 20
Registriert: 14.09.2018, 18:07

Re: Probleme mit Unterseite seit letztem Update

Beitrag von Meerengel » 16.09.2022, 14:20

Mein Webdesigner kann auf dem Server kein Error-Log finden, weder im Ordner für SWM noch im allgemeinen Meerengel.de-Verzeichnis.

Auf Hosteurope wird folgendes angezeigt. Wir könnten auch komplette Errorfiles herunterladen, wenn es so nicht reicht.

[Fri Sep 16 01:25:11 2022] [ssl:warn] [pid 11874] [client [host AH01909: meerengel.de:443:0 server certificate does NOT include an ID which matches the server name
[Fri Sep 16 01:30:44 2022] [php:error] [pid 23658] [client 216.244.66.237] [host www.meerengel.de] script '/is/htdocs/wp10678107_8UIBX8C47J/www/product_info.php' not found or unable to stat
[Fri Sep 16 01:32:55 2022] [php:error] [pid 27550] [client 216.244.66.237] [host www.meerengel.de] script '/is/htdocs/wp10678107_8UIBX8C47J/www/product_reviews_write.php' not found or unable to stat
[Fri Sep 16 11:48:56 2022] [ssl:warn] [pid 11874] [client [host AH01909: meerengel.de:443:0 server certificate does NOT include an ID which matches the server name
[Fri Sep 16 11:50:29 2022] [php:error] [pid 29023] [client 216.244.66.237] [host www.meerengel.de] script '/is/htdocs/wp10678107_8UIBX8C47J/www/featured_products.php' not found or unable to stat
[Fri Sep 16 13:51:37 2022] [php:error] [pid 5499] [client 216.244.66.237] [host www.meerengel.de] script '/is/htdocs/wp10678107_8UIBX8C47J/www/ask_a_question_popup.php' not found or unable to stat
[Fri Sep 16 13:51:42 2022] [php:error] [pid 5582] [client 216.244.66.237] [host www.meerengel.de] script '/is/htdocs/wp10678107_8UIBX8C47J/www/ask_a_question_popup.php' not found or unable to stat

Ich hoffe, du kannst uns weiterhelfen. Danke dir!

Benutzeravatar
mirko
Beiträge: 22519
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Probleme mit Unterseite seit letztem Update

Beitrag von mirko » 15.09.2022, 11:18

Das error_log der Webpräsenz anschauen, falls es die Datei error_log gibt. Per SSH oder FTP kann man zugreifen und die Datei im log oder stat-Verzeichnis der Webpräsenz oft runterladen/anschauen.

Meerengel
Beiträge: 20
Registriert: 14.09.2018, 18:07

Re: Probleme mit Unterseite seit letztem Update

Beitrag von Meerengel » 14.09.2022, 13:35

leider auch darunter keine Veränderung. Bei Firefox weiterhin eine leere Seite. Egal ob neu angelegtes Mailing oder bestehendes. Bei Google Crome "diese Seite funktioniert nicht. www.meerengel.de kann diese Anfrage momentan nicht verarbeiten.
HTTP ERROR 500
Hast du noch eine andere Idee?

Benutzeravatar
mirko
Beiträge: 22519
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Probleme mit Unterseite seit letztem Update

Beitrag von mirko » 12.09.2022, 12:08

immer das Debug aktivieren, sonst sieht man einfach nichts, weil die Fehleranzeige im Browser und den Logfiles komplett deaktiviert ist.

Meerengel
Beiträge: 20
Registriert: 14.09.2018, 18:07

Re: Probleme mit Unterseite seit letztem Update

Beitrag von Meerengel » 12.09.2022, 11:10

Hallo Mirko,
wir haben das Update nochmal ausgeführt. Auf PHP 7.4 läuft alles. Auf PHP 8.1 kann ich zwar ein Mailing anlegen, komme aber nicht in die Vorlagen oder bereits versendete Kampagnen. Sollen wir das Debug ausführen oder hast du noch eine andere Idee? Danke dir!
mirko hat geschrieben:
06.09.2022, 18:25
Die Seite/Datei browsecampaigns.php nochmals einspielen.

Hilft das nicht, könnten andere Dateien nicht aktuell sein.

Datei userdefined.inc.php runterladen, im Texteditor öffnen vor define('DEBUG', 1); Raute-Zeichen # entfernen, speichern, hochladen und schauen ob beim nächsten Aufruf eine Fehlermeldung erscheint.

Meerengel
Beiträge: 20
Registriert: 14.09.2018, 18:07

Re: Probleme mit Unterseite seit letztem Update

Beitrag von Meerengel » 06.09.2022, 21:41

Herzlichen Dank Mirko! Soweit ich das sehe, klappt jetzt wieder alles!

Antworten