Google recaptcha funktioniert nicht

PHP Newsletter Software/Script und E-Mail-Marketing Software SuperWebMailer

Moderator: mirko

Antworten
Benutzeravatar
mirko
Beiträge: 21628
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Google recaptcha funktioniert nicht

Beitrag von mirko » 05.09.2019, 12:06

zuerst mal unter Menü Webseite - HTML-Seiten-/Umleitungen die anzuzeigende Seite im Quelltext ändern und die Stylesheet-Angabe auf https:// ändern, das wird geblockt, weil der Stylesheet per http:// geladen wird

Die Captcha-Daten werden korrekt zum Webserver geschickt, nur ob die korrekt ankommen, kann man nicht sehen. Ich denke mal der https://-Aufruf zu Google scheitert, mal bei einem E-Mailing beim Editor eine HTML-Datei per https:// laden lassen, falls das überhaupt geht.

aardon
Beiträge: 8
Registriert: 18.07.2014, 12:22

Re: Google recaptcha funktioniert nicht

Beitrag von aardon » 03.09.2019, 12:45

Wenn ich das über die Superwebmailer-Demo anlege, funktioniert es, sowohl wenn ich das externe Formular verwende, als auch wenn ich den HTML-Code in Wordpress einfüge.

Wenn ich es über meine eigene Installation anlege, funktioniert beides nicht, auch nicht das externe Formular (also kein Wordpress-Problem).
Hier mal der Link zum Formular: https://www.firmennetz.de/mail/defaultn ... rm=subform

Benutzeravatar
mirko
Beiträge: 21628
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Google recaptcha funktioniert nicht

Beitrag von mirko » 02.09.2019, 18:25

dann anderen Browser verwenden und damit testen. Alternativ im Demo www.superwebmailer.de eigene Liste einfügen, damit testen.

aardon
Beiträge: 8
Registriert: 18.07.2014, 12:22

Re: Google recaptcha funktioniert nicht

Beitrag von aardon » 02.09.2019, 18:14

Ja, auch das habe ich berücksichtigt

Benutzeravatar
mirko
Beiträge: 21628
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Google recaptcha funktioniert nicht

Beitrag von mirko » 02.09.2019, 18:11

ist es auch reCaptcha v2, nicht v3 verwenden

aardon
Beiträge: 8
Registriert: 18.07.2014, 12:22

Re: Google recaptcha funktioniert nicht

Beitrag von aardon » 02.09.2019, 16:46

Also ich habe alles noch einmal überprüft:
- SSL passt
- Firewall blockt nicht
- Schlüssel stimmt
- keine Javascript Fehlermeldungen in der Console

Benutzeravatar
mirko
Beiträge: 21628
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Google recaptcha funktioniert nicht

Beitrag von mirko » 24.08.2019, 18:06

an dem WordPress wird es liegen, damit funktioniert das Recaptcha vielleicht nicht. Im Browser mit F12 die Developer Console öffnen und schauen ob es JavaScript-Fehler gibt

aardon
Beiträge: 8
Registriert: 18.07.2014, 12:22

Re: Google recaptcha funktioniert nicht

Beitrag von aardon » 24.08.2019, 13:37

Also die Website unterstützt SSL und der Schlüssel ist richtig.
Wegen der Firewall muss ich mal bei meinem Hoster nachfragen.

Ich habe in der Zwischenzeit jetzt mal das interne Captcha verwendet.
Allerdings konnte ich auch hier nur den Link auf das vorgegebene Formular verwenden und nicht die HTML-Einbindung, weil die Website auf Wordpress läuft und PHP dort immer ein bisschen schwierig ist.
Kann man das Default-Formular auf das man verlinken kann irgendwo anpassen?

Liebe Grüße
Stefan

Benutzeravatar
mirko
Beiträge: 21628
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Google recaptcha funktioniert nicht

Beitrag von mirko » 23.08.2019, 11:13

Bei (2) ist der https://-Aufruf zu Google gescheitert, mögliche Ursache:

* eigene Webseite unterstützt kein SSL
* Firewall auf dem Webspace blockt
* Schlüssel falsch eingegeben

Die Meldung "Geben Sie das angezeigte Wort korrekt ein" kann man unter Menü Webseite - Meldungstexte "Text wenn die Captcha-Zeichenkette..." selbst anpassen.

aardon
Beiträge: 8
Registriert: 18.07.2014, 12:22

Google recaptcha funktioniert nicht

Beitrag von aardon » 23.08.2019, 10:29

Hallo,

ich muss meine Newsletterformulare schützen, weil ich Opfer eines Robots wurde.
Ich wollte dies jetzt mit der Option Google recaptcha V2 tun.
Die Einbindung etc. klappt auch, aber wenn man ankreuzt "Ich bin kein Roboter" und dann das Formular abschickt erscheint von Superwebmailer die Meldung:

Es ist ein Fehler aufgetreten:
Geben Sie das angezeigte Wort korrekt ein.(2)

Man muss aber bei Recaptcha V2 ja gar kein Wort eingeben, sondern nur dieses Feld ankreuzen "Ich bin kein Roboter"

Was läuft hier falsch?

Liebe Grüße
Stefan

Antworten