Hilfe! Ausgangswarteschlage voll! Ereignisprotokoll hängt

PHP Newsletter Software/Script und E-Mail-Marketing Software SuperWebMailer

Moderator: mirko

Antworten
Benutzeravatar
mirko
Beiträge: 21608
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Hilfe! Ausgangswarteschlage voll! Ereignisprotokoll hängt

Beitrag von mirko » 06.08.2019, 21:36

the_scrat hat geschrieben:
06.08.2019, 21:19
Das muss man nicht, in den Unterverzeichnissen von userfiles/(meistens 2) alles löschen, wäre auch aufgeräumt. Die Updates sind die gleiche Dateien wie die komplette Version, macht keinen Unterschied.
Das meine ich nicht, in userfiles/(2) liegen ja nur die Userfiles. Allerdings gibt es ja unzählige Dateien die bei den Updates hinzugefügt wurde und später wieder entfernt werden müssten z.B. ckeditor oder /captcha/require, diverse Dateien von /FusionCharts oder /js/canvasjs
Ich hab die letzten Jahre eigentlich immer nur die swm entpackt und dann einfach alles in eine Richtung auf den FTP (natürlich mit Sicherung usw.) hat wunderbar funktioniert.
ja das stimmt, die Dateien sollte man löschen, muss man aber nicht, liegen halt sinnlos rum.
Bzgl Tabellen reparieren, reicht da die "Tabellen reparieren" Funktion aus der Datenbankwartung im SWM oder sollte ich das direkt mal im PHPMyAdmin machen?
Wenn es sehr viele E-Mailings sind, dann nach und nach im phpMyAdmin.

the_scrat
Beiträge: 131
Registriert: 07.09.2010, 16:20

Re: Hilfe! Ausgangswarteschlage voll! Ereignisprotokoll hängt

Beitrag von the_scrat » 06.08.2019, 21:19

Das muss man nicht, in den Unterverzeichnissen von userfiles/(meistens 2) alles löschen, wäre auch aufgeräumt. Die Updates sind die gleiche Dateien wie die komplette Version, macht keinen Unterschied.
Das meine ich nicht, in userfiles/(2) liegen ja nur die Userfiles. Allerdings gibt es ja unzählige Dateien die bei den Updates hinzugefügt wurde und später wieder entfernt werden müssten z.B. ckeditor oder /captcha/require, diverse Dateien von /FusionCharts oder /js/canvasjs
Ich hab die letzten Jahre eigentlich immer nur die swm entpackt und dann einfach alles in eine Richtung auf den FTP (natürlich mit Sicherung usw.) hat wunderbar funktioniert.

Bzgl Tabellen reparieren, reicht da die "Tabellen reparieren" Funktion aus der Datenbankwartung im SWM oder sollte ich das direkt mal im PHPMyAdmin machen?

Benutzeravatar
mirko
Beiträge: 21608
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Hilfe! Ausgangswarteschlage voll! Ereignisprotokoll hängt

Beitrag von mirko » 06.08.2019, 18:05

the_scrat hat geschrieben:
06.08.2019, 11:51
Danke für die schnelle Reaktion.

Ich habe verschiedene Versandvarianten angelegt. Die meisten gehen über die Server von Domainfactory raus. Hier habe ich auch mit dem Support telefoniert, er meinte es gäbe dort schon immer ein Limit von 250 Mails pro Stunde, was mir tatsächlich neu war. Habe das Limit mal auf 1000 anheben lassen. Dennoch komisch, dass das in den letzten Jahren noch nie zum Problem wurde.
Ja das gibt es aber wie lange es das gibt, weiß ich nicht.
Die Installation habe ich jetzt dennoch einmal neu aufgesetzt. Schon alleine weil ich seit 10 Jahren Updates einspiele und hier im direct Vergleich der Verzeichnisse so viel Quatsch überflüssig drin war, dass es bitterlich notwendig war, hier mal ne saubere Struktur aufzusetzen.
Das muss man nicht, in den Unterverzeichnissen von userfiles/(meistens 2) alles löschen, wäre auch aufgeräumt. Die Updates sind die gleiche Dateien wie die komplette Version, macht keinen Unterschied.
Um das zu testen habe ich den swm mal ganz neu (inkl. neuer DB) installiert. Hier konnte ich mit dem gleichen Browser die Versandvarianten testen und der Dialog zeigte mir auch die Felder an um hier einen Testversand zu machen.
Anschließend habe ich die neue Installation mit der "alten" DB verbunden (config.db.inc) und hatte keinen Zugriff mehr auf den Dialog der Versandvarianten. Danach exportierte ich aus swm_mtas die Einträge in die neue "leere" DB, wobei es hier wohl noch zwei veraltete Einträge gab (MailLimitWaitTime, MailLimitDateTime). Habe diese kurz erstellt, die Einträge übernommen und hatte direkt wieder Zugriff auf den Dialog.
Vielleicht war eine Tabelle defekt, z.B. weil die MySQL-Datenbank bzw. der Server einfach ausgeschaltet wurde. Das hatte ich schon öfter, man muss danach alle Tabellen reparieren lassen, sonst kann es seltsame Fehler geben.

the_scrat
Beiträge: 131
Registriert: 07.09.2010, 16:20

Re: Hilfe! Ausgangswarteschlage voll! Ereignisprotokoll hängt

Beitrag von the_scrat » 06.08.2019, 11:51

Danke für die schnelle Reaktion.

Ich habe verschiedene Versandvarianten angelegt. Die meisten gehen über die Server von Domainfactory raus. Hier habe ich auch mit dem Support telefoniert, er meinte es gäbe dort schon immer ein Limit von 250 Mails pro Stunde, was mir tatsächlich neu war. Habe das Limit mal auf 1000 anheben lassen. Dennoch komisch, dass das in den letzten Jahren noch nie zum Problem wurde.

Die Installation habe ich jetzt dennoch einmal neu aufgesetzt. Schon alleine weil ich seit 10 Jahren Updates einspiele und hier im direct Vergleich der Verzeichnisse so viel Quatsch überflüssig drin war, dass es bitterlich notwendig war, hier mal ne saubere Struktur aufzusetzen.

Um das zu testen habe ich den swm mal ganz neu (inkl. neuer DB) installiert. Hier konnte ich mit dem gleichen Browser die Versandvarianten testen und der Dialog zeigte mir auch die Felder an um hier einen Testversand zu machen.
Anschließend habe ich die neue Installation mit der "alten" DB verbunden (config.db.inc) und hatte keinen Zugriff mehr auf den Dialog der Versandvarianten. Danach exportierte ich aus swm_mtas die Einträge in die neue "leere" DB, wobei es hier wohl noch zwei veraltete Einträge gab (MailLimitWaitTime, MailLimitDateTime). Habe diese kurz erstellt, die Einträge übernommen und hatte direkt wieder Zugriff auf den Dialog.

Also das ist alles sehr merkwürdig.

Alte Mails hab ich schon gelöscht, Danke für den Hinweis.

Benutzeravatar
mirko
Beiträge: 21608
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Hilfe! Ausgangswarteschlage voll! Ereignisprotokoll hängt

Beitrag von mirko » 06.08.2019, 11:13

War bestimmt ein Problem mit dem E-Mail-Server, der hing irgendwie an einer E-Mail, das kommt vor, darf man nicht gleich in Panik verfallen. :D

Nicht neu installieren, das ändert doch nichts.

Der Fehler bei Versandvariante testen:

* anderen Browser probieren
* in der Datei userdefined.inc.php, vor define('DEBUG', 1); Raute-Zeichen (#) entfernen, ausprobieren und error_log der Webpräsenz prüfen

Immer gilt: Alte E-Mailings löschen, die kosten viel Speicherplatz in der DB und machen alles langsamer

the_scrat
Beiträge: 131
Registriert: 07.09.2010, 16:20

Re: Hilfe! Ausgangswarteschlage voll! Ereignisprotokoll hängt

Beitrag von the_scrat » 06.08.2019, 09:14

Die Mails gehen übrigens dann schon raus. Jetzt um kurz nach 9 Uhr sind alle ca. 200 Mails in der Ausgangswarteschlange abgearbeitet. Seitdem zeigt er auch keine weiteren Fehler oder Sanduhren im Ereignisprotokoll mehr an.

Ich wollte vorher auch gerade mal die Versandvarianten testen, jedoch beim Öffnen des Dialogs zeigt er mir nur den Dialog, nicht jedoch den Inhalt an. Irgendwas stimmt mit der Installation nicht.

Wäre es möglich, wenn ich swm_full einmal neu sauber installiere und anschließend in den config.* Dateien die DB und Pfade anpasse? und natürlich userfiles/2 kopieren.? Müsste das hinhauen? Oder gibt es da noch mehr zu beachten?

the_scrat
Beiträge: 131
Registriert: 07.09.2010, 16:20

Hilfe! Ausgangswarteschlage voll! Ereignisprotokoll hängt

Beitrag von the_scrat » 06.08.2019, 08:23

Hallo Mirko,

ich habe seit gestern ein sehr komisches Problem. Nämlich, dass die Ausgangswarteschlange voll ist und die Mails extrem langsam verschickt werden.
Im Ereignisprotokoll hängt ständig der Punkt "Prüfung auf zu versendende E-Mails"

Ich hatte das selbe Problem gestern schon, als ich ein normales Mailing weggeschickt habe. Heute morgen werden (wie seit nun 10 Jahren) die täglichen FollowUp verschickt (es wurde nichts geändert an den Einstellungen) und die gehen nicht raus.

Der Cron ist auch blockiert für 30 Min und im Verzeichnis wurde eine .lock Datei erstellt für den Block

Weißt du hier rat?
Ereignisprotokoll.png
Ereignisprotokoll.png (252.01 KiB) 319 mal betrachtet
Ereignissprotokoll_Detail.png
Ereignissprotokoll_Detail.png (31.12 KiB) 319 mal betrachtet
Einstellungen.png
Einstellungen.png (52.41 KiB) 319 mal betrachtet

Antworten