Häufige Beschwerden über nicht funktionierende Abmeldungen

PHP Newsletter Software/Script und E-Mail-Marketing Software SuperWebMailer

Moderator: mirko

Antworten
Benutzeravatar
mirko
Beiträge: 21428
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von mirko » 13.12.2018, 11:27

das mit dem blocked war nur ein Beispiel

ist kein Fehler, haben Sie doch selbst getestet, der Link funktioniert und eine Abmeldung erfolgt

Es lässt sich kein Fehler finden, wahrscheinlich ist es ein Problem auf dem Rechner des Empfängers, vielleicht wird im Browser etwas geblockt oder ein Proxy-Server im Netzwerk des Empfängers verändert den Link. Was es ist, bekommt man nicht raus, an dem Link lässt sich auch nichts ändern, der ist syntaktisch vollkommen korrekt.

sikue
Beiträge: 72
Registriert: 31.08.2009, 12:06

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von sikue » 13.12.2018, 10:01

Vielen Dank. :)

Der besagte Kunde hat sich zurückgemeldet. Allerdings wurde der Link meiner Ansicht nach bei ihm nicht verändert.
Hier die Kundenmeldung:

---
Sehr geehrte Frau ...,

nachfolgend kopiere ich Ihnen den Browserlink hier ein:

.../nlu.php?key=F9A4-04-02-98A2CD7EFA1BA950D42E42AF495C4248-20B3230037BDC8FFEE7&rid=01_02_04_2C6_x01&RG=27

Nachdem ich auf Abmelden klicke, öffnet sich das neue Fenster und es wird angezeigt, dass meine Abmeldung erfolgreich gespeichert wurde. Das Wort "blocked" finde ich nicht.

Ich hoffe, Sie finden den Fehler.

Mit freundlichen Grüßen

...



----

Benutzeravatar
mirko
Beiträge: 21428
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von mirko » 12.12.2018, 14:20

Ich habe das jetzt selbst getestet, in Verbindung mit den Gruppen gibt es einen Fehler bei der Abmeldung bzw. eher beim Ausgabetext.

Wenn derjenige sich abmeldet, dann erscheint die Meldung "Sie wurden abgemeldet", meldet er sich nochmals über den gleichen Link ab, kommt wieder "Sie wurden abgemeldet" usw., also man kann klicken so oft man will, kommt immer der gleiche Text. Es kommt niemals "Sie befinden sich nicht in der Liste". Im Hintergrund wurde derjenige natürlich aus den jeweiligen Gruppen schon beim ersten Klick gelöscht. Nach dem nächsten Update wird dann ausgegeben, dass derjenige nicht mehr vorhanden ist.

Manchmal gibt es Antiviren-Programme, die verändern die Links, dann funktioniert der nicht. Die fügen in alle externen Links z.B. *blocked* ein, muss man als Anwender mitdenken und das *blocked* entfernen.

sikue
Beiträge: 72
Registriert: 31.08.2009, 12:06

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von sikue » 12.12.2018, 11:39

Hi nochmal,

ich habe gerade einiges Tests durchgeführt.
Ich kann das nicht nachstellen, was die Kunden sagen.
Wann immer ich mich abmelde, sehe ich die Bestätigungsseite im Browser und erhalte auch eine Bestätigungsmail.
Aus der Untergruppe bin ich auch raus und wenn ich das Mailing mal testhalber dupliziere und nochmal versenden will,
bin ich nicht mehr dabei. Für den Test habe ich mich extra in mehr als eine Untergruppe eingetragen.

Dennoch erhalten wir bei jedem Mailing ungefähr 10 Beschwerden von Kunden, die sagen, dass sie sich bereits mehrfach abgemeldet haben.
Ich weiß nicht, welche Tests ich jetzt noch machen könnte.

Kann sich der Abmeldelink auf unterschiedlichen Betriebssystemen oder in unterschiedlichen Browsern anders verhalten?
Logisch klingt es nicht, aber wenn der Fehler nicht im SuperWebMailer direkt liegt, kann es ja nur noch in der Interpretation des Links selbst liegen...

Haben Sie eine Idee, was ich noch testen könnte?

Grüße,
Sikue

Benutzeravatar
mirko
Beiträge: 21428
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von mirko » 12.12.2018, 11:18

sikue hat geschrieben:
12.12.2018, 10:16
Hallo,

ich habe jetzt so eine Mail vom Kunden zugestellt bekommen, der sagt, er kann sich nicht abmelden.
Ich habe also mal den Original-Link in der Mail angeklickt und es öffnet sich dann auch ein Fenster mit der Bestätigung der Abmeldung.
Wenn ich in der Empfängerliste nachschaue, ist die Mailadresse aus der Untergruppe auch entfernt worden (in anderen Gruppen ist sie noch drin).

Allerdings habe ich es so eingestellt, dass man beim Abmelden auf die lokale Blockliste kommen soll.
Dies ist mit dieser Adresse nicht geschehen.
Liegt es daran, dass die Adresse noch in anderen Untergruppen drin steht?
So ist es. Erst wenn derjenige endgültig gelöscht wird, dann wird der Eintrag in der lokalen Blockliste erzeugt, ansonsten würde derjenige keine E-Mails mehr bekommen, wenn man an die anderen Gruppen versenden lässt.
Nun bleibt noch die Frage, warum die Adresse bei meinem Klick aus der Untergruppe entfernt wurde, beim Klick des Kunden aber nicht.
Ich gehe schon davon aus, dass der Kunde in der Lage ist, einen Link anzuklicken. Er sagt auch, dass die Bestätigungsseite aufging.

Dies hier ist der verwendete Abmeldelink:
../nlu.php?key=F9A4-04-02-98A2CD7EFA1BA950D42E42AF495C4248-20B3230037BDC8FFEE7&rid=01_02_04_2C6_x01&RG=27

Klicke ich ihn übrigens nochmal an, erscheint wieder die Bestätigungsseite.
Es erscheint nicht, dass diese Adresse schon nicht mehr enthalten ist.
Das teste ich mal, vielleicht gibt er in Verbindung mit den Gruppen immer die Bestätigungsseite aus, obwohl derjenige gelöscht wurde bzw. gar nicht mehr in der Gruppe ist.

sikue
Beiträge: 72
Registriert: 31.08.2009, 12:06

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von sikue » 12.12.2018, 10:16

Hallo,

ich habe jetzt so eine Mail vom Kunden zugestellt bekommen, der sagt, er kann sich nicht abmelden.
Ich habe also mal den Original-Link in der Mail angeklickt und es öffnet sich dann auch ein Fenster mit der Bestätigung der Abmeldung.
Wenn ich in der Empfängerliste nachschaue, ist die Mailadresse aus der Untergruppe auch entfernt worden (in anderen Gruppen ist sie noch drin).

Allerdings habe ich es so eingestellt, dass man beim Abmelden auf die lokale Blockliste kommen soll.
Dies ist mit dieser Adresse nicht geschehen.
Liegt es daran, dass die Adresse noch in anderen Untergruppen drin steht?

Nun bleibt noch die Frage, warum die Adresse bei meinem Klick aus der Untergruppe entfernt wurde, beim Klick des Kunden aber nicht.
Ich gehe schon davon aus, dass der Kunde in der Lage ist, einen Link anzuklicken. Er sagt auch, dass die Bestätigungsseite aufging.

Dies hier ist der verwendete Abmeldelink:
../nlu.php?key=F9A4-04-02-98A2CD7EFA1BA950D42E42AF495C4248-20B3230037BDC8FFEE7&rid=01_02_04_2C6_x01&RG=27

Klicke ich ihn übrigens nochmal an, erscheint wieder die Bestätigungsseite.
Es erscheint nicht, dass diese Adresse schon nicht mehr enthalten ist.

Grüße,
Sikue

Benutzeravatar
mirko
Beiträge: 21428
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von mirko » 06.12.2018, 16:35

darunter sind die Links
Dateianhänge
Bild1.png
Bild1.png (11.53 KiB) 74 mal betrachtet

sikue
Beiträge: 72
Registriert: 31.08.2009, 12:06

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von sikue » 06.12.2018, 11:42

Hallo :)

ich werde versuchen von noch zugänglichen Kunden die Mail als Datei oder Weiterleitung zu bekommen. Ist schwierig, aber vielleicht ist ja jemand hilfsbereit.

Zu dem generellen Abmeldelink:
Der Link endet beispielsweise so: /defaultnewsletter.php?ML=30&F=1
Wie ist das nun mit dem IdentString als Parameter gemeint?

Grüße,
Sikue

Benutzeravatar
mirko
Beiträge: 21428
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von mirko » 05.12.2018, 11:35

Um den Fehler nachstellen zu können, müsste derjenige die Original-E-Mail weiterleiten bzw. besser noch als Datei speichern und als Anhang zur Prüfung weiterleiten. Vielleicht wurde der Abmeldelink durch ein Antiviren-Programm oder ähnliches verändert, dann funktioniert der natürlich nicht mehr.

Wenn man nur an eine bestimmte Gruppe E-Mails versendet, dann wird derjenige bei Abmeldung natürlich aus der Gruppe gelöscht, nicht aus den anderen Gruppen. Entsprechend bekommt derjenige weiterhin E-Mails, wenn man an eine andere Gruppe E-Mails versendet, in der derjenige enthalten ist.

Soll ein Abmeldelink verwendet werden, der den Empfänger komplett bei Abmeldung ohne Berücksichtigung der Gruppen löscht, dann muss man manuell den Abmeldelink einfügen. Unter Menü Webseite - An-/Abmeldeformulare für die jeweilige Empfängerliste den Formularcode erzeugen lassen, irgendwas wählen, unter dem erzeugten Code stehen immer die direkten Abmeldelinks, man muss den Link mit [IdentString] als Parameter verwenden. Wenn man diese Variante verwendet, dann vielleicht 2 Abmeldelinks verwenden, halt den normalen Platzhalter [UnsubscribeLink] und davor angeben "Abmeldung aus Gruppe xyz" und "Komplette Abmeldung für immer", dann den direkten Abmeldelink einfügen.

sikue
Beiträge: 72
Registriert: 31.08.2009, 12:06

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von sikue » 04.12.2018, 12:56

Hallo,

wir haben nichts gelöscht. :(
Es ist eine schon lange im Gebrauch befindliche Empfängerliste.
Ob sich die Leute nur früher nicht beschwert haben und das nun erst tun, seit die DSGVO durch die Medien geprügelt wurde, kann ich natürlich nicht sagen.

Ich habe leider keinen Schimmer, wo ich mit der Suche noch ansetzen könnte, zumal ich das selbst in meinen Tests nicht nachstellen kann.
Das Einzige, was mir aufgefallen ist, was aber ja faktisch richtig ist, ist die Tatsache, dass die Empfänger beim Abmelden nur von der Untergruppe der Empfängerliste ausgetragen werden. Ich halte das für richtig so - und ich wüsste auch nicht, wie man eine Abmeldung machen könnte, die sich auf die gesamte Empfängerliste bezieht?

Grüße,
Sikue

Benutzeravatar
mirko
Beiträge: 21428
Registriert: 25.11.2001, 15:14
Wohnort: Leipzig
Kontaktdaten:

Re: Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von mirko » 04.12.2018, 12:19

Man darf nach dem Versand eines Newsletters nicht die Empfängerliste löschen und z.B. neu importieren, es ist dann keine Abmeldung mehr möglich, weil die sich der eindeutige Identifikationsstring des Empfänger ändert. Man kann natürlich auch den selbst den Abmeldelink einfügen und die E-Mail-Adresse des Empfängers übergeben lassen, dann funktioniert der Link immer, das sollte aber eigentlich wegen der DSGVO nicht mehr gemacht werden.

sikue
Beiträge: 72
Registriert: 31.08.2009, 12:06

Häufige Beschwerden über nicht funktionierende Abmeldungen

Beitrag von sikue » 03.12.2018, 13:56

Hallo,

wir haben einige, unterschiedliche Empfängerlisten und nur eine davon macht immer wieder Probleme bei den Abmeldungen.
Ich kann nicht erkennen, woran es liegt.

In allen Newslettern ist der ganz normale Abmeldelink enthalten. Nun melden sich häufig Personen, die sich bitterböse beschweren, dass sie den Abmeldelink schon zig mal gedrückt hätten, aber nicht ausgetragen wurden.

Wann immer ich das selbst teste, funktioniert die Abmeldung tadellos.
Daher habe ich mittlerweile einige von den noch zugänglichen Kunden gefragt, wie sie vorgegangen sind, welchen Browser sie verwendet haben, usw.
Dabei kamen allerdings keine Informationen zutage, die ungewöhnlich wären.
Die Kunden gehen genau wie ich vor.

Ich habe sowohl auf dem PC (mit Firefox und Chrome), als auch auf dem Smartphone (Safari) getestet.
Bei mir klappt es immer!

Ich kann mir jedoch nicht vorstellen, dass zig Kunden Unsinn erzählen...zumal es mittlerweile sicherlich schon 20 oder mehr Beschwerden gab. Alle sagen einheitlich aus, dass sie die Abmeldung bereits mehrfach durch den Klick auf den Abmeldelink im Newsletter furchgeführt haben.
(Natürlich habe ich diese Kunden dann manuell entfernt.)

Wo kann ich hier noch suchen?

Grüße,
Sikue

Antworten