Problem mit Anhängen

Probleme, Tipps & Tricks zu LANMailServer

Moderator: mirko

Benutzeravatar
mirko
Beiträge: 21001
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 08.01.2007, 16:32

jetzt bräuchte ich mal die Postfachdatei per E-Mail (aber gezippt) an info@<programmname>.de <programmname> = LANMailserver

Bodemann
Beiträge: 4
Registriert: 07.01.2007, 14:27

Beitragvon Bodemann » 08.01.2007, 14:55

Hab\' ich eingespielt. Hier der Logfile-Eintrag des Thunderbird. Da gibt es einen Fehler.

192.168.192.50:1448 Stat Connected.
192.168.192.50:1448 Sent 08.01.2007 14:47:48: +OK Welcome to LANMailServer 1.25 POP3 Server<EOL>
192.168.192.50:1448 Recv 08.01.2007 14:47:48: AUTH<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: -ERR-Sorry, Unknown Command<EOL>-ERR AUTH<EOL>
192.168.192.50:1448 Recv 08.01.2007 14:47:48: CAPA<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: +OK Capability list follows<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: UIDL<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: USER<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: .<EOL>
192.168.192.50:1448 Recv 08.01.2007 14:47:48: USER bodemann<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: +OK Password required<EOL>
192.168.192.50:1448 Recv 08.01.2007 14:47:48: PASS pwd<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: +OK Login OK<EOL>
192.168.192.50:1448 Recv 08.01.2007 14:47:48: STAT<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: +OK 1 4821667<EOL>
192.168.192.50:1448 Recv 08.01.2007 14:47:48: LIST<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: +OK 1 messages (4821667 octets)<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: 1 4821667<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: .<EOL>
192.168.192.50:1448 Recv 08.01.2007 14:47:48: UIDL<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: +OK<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: 1 82122708.01.200712:00:28<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: .<EOL>
192.168.192.50:1448 Recv 08.01.2007 14:47:48: RETR 1<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: +OK 4821667 octets<EOL>
192.168.192.50:1448 Sent 08.01.2007 14:47:48: Received: from Kyocera[192.168.192.27] (helo=Kyocera) by blaupause[192.168.192.50] with esmtp (LANMailServer 1.20)<EOL>Date: Mon 08 Jan 2007 11:59:24 +0100<EOL>From: kyocera@blaupause.de<EOL>Subject: Kyocera Scanner<EOL>To: bodemann@blaupause.de<EOL>Mime-Version: 1.0<EOL>Content-Type: multipart/mixed;<EOL> boundary=\"boundary Mon 08 Jan 2007 11:59:24 +0100 boundary\"<EOL>Content-Transfer-Encoding: 8bit<EOL>X-PEERIP: 192.168.192.27<EOL>X-UIDL: 482122708.01.200712:00:28
192.168.192.50:1448 Sent 08.01.2007 14:47:48: <EOL>


Hier das Gleiche mit Outlook Express 6

192.168.192.31:4554 Stat Connected.
192.168.192.31:4554 Sent 08.01.2007 14:50:40: +OK Welcome to LANMailServer 1.25 POP3 Server<EOL>
192.168.192.31:4554 Recv 08.01.2007 14:50:40: USER bodemann<EOL>
192.168.192.31:4554 Sent 08.01.2007 14:50:40: +OK Password required<EOL>
192.168.192.31:4554 Recv 08.01.2007 14:50:40: PASS pwd<EOL>
192.168.192.31:4554 Sent 08.01.2007 14:50:40: +OK Login OK<EOL>
192.168.192.31:4554 Recv 08.01.2007 14:50:40: STAT<EOL>
192.168.192.31:4554 Sent 08.01.2007 14:50:40: +OK 1 4821667<EOL>
192.168.192.31:4554 Recv 08.01.2007 14:50:40: LIST<EOL>
192.168.192.31:4554 Sent 08.01.2007 14:50:40: +OK 1 messages (4821667 octets)<EOL>
192.168.192.31:4554 Sent 08.01.2007 14:50:40: 1 4821667<EOL>
192.168.192.31:4554 Sent 08.01.2007 14:50:40: .<EOL>
192.168.192.31:4554 Recv 08.01.2007 14:50:40: RETR 1<EOL>
192.168.192.31:4554 Sent 08.01.2007 14:50:40: +OK 4821667 octets<EOL>
192.168.192.31:4554 Sent 08.01.2007 14:50:40: Received: from Kyocera[192.168.192.27] (helo=Kyocera) by blaupause[192.168.192.50] with esmtp (LANMailServer 1.20)<EOL>Date: Mon 08 Jan 2007 11:59:24 +0100<EOL>From: kyocera@blaupause.de<EOL>Subject: Kyocera Scanner<EOL>To: bodemann@blaupause.de<EOL>Mime-Version: 1.0<EOL>Content-Type: multipart/mixed;<EOL> boundary=\"boundary Mon 08 Jan 2007 11:59:24 +0100 boundary\"<EOL>Content-Transfer-Encoding: 8bit<EOL>X-PEERIP: 192.168.192.27<EOL>X-UIDL: 482122708.01.200712:00:28
192.168.192.31:4554 Sent 08.01.2007 14:50:40: <EOL>

Funktioniert beides leider nicht.

Gruß, Jörn

Benutzeravatar
mirko
Beiträge: 21001
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 08.01.2007, 14:42

unter www.lanmailserver.de/test/lms.zip liegt eine leicht geändert Version. Diese laden, LANMailServer beenden, die ZIP-Datei in den LANMailServer Programmordner auspacken, bestehende lanmailserver.exe ersetzen lassen und LANMailServer wieder starten.
So wie das aussieht hat er ein Problem nach dem Header der Mail, so als ob der Body nicht gesendet werden kann, weil zu wenig Speicher verfügbar ist.

Bodemann
Beiträge: 4
Registriert: 07.01.2007, 14:27

Beitragvon Bodemann » 08.01.2007, 12:22

Ich verwende ebenfalls Thunderbird 1.5.0.9. Wie vorgeschlagen habe ich versucht, die Emails mit Outlook Express abzuholen. Dafür habe ich eine kleine (794,5 KB laut Angabe in der LMS Lokal Queue) und eine große (4.6 MB) erzeugt. Hier zunächst das Logfile der Kleinen. Diese Ãœbertragung hat funktioniert.

192.168.192.31:2443 Stat Connected.
192.168.192.31:2443 Sent 08.01.2007 11:53:17: +OK Welcome to LANMailServer 1.20 POP3 Server<EOL>
192.168.192.31:2443 Recv 08.01.2007 11:53:17: USER bodemann<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: +OK Password required<EOL>
192.168.192.31:2443 Recv 08.01.2007 11:53:17: PASS pwd<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: +OK Login OK<EOL>
192.168.192.31:2443 Recv 08.01.2007 11:53:17: STAT<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: +OK 1 813544<EOL>
192.168.192.31:2443 Recv 08.01.2007 11:53:17: LIST<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: +OK 1 messages (813544 octets)<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: 1 813544<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: .<EOL>
192.168.192.31:2443 Recv 08.01.2007 11:53:17: RETR 1<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: +OK 813544 octets)<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: Received: from
Kyocera[192.168.192.27] (helo=Kyocera) by blaupause[192.168.192.50] with esmtp (LANMailServer 1.20)<EOL>Date: Mon 08 Jan 2007 11:52:26 +0100<EOL>From: kyocera@e.de<EOL>Subject: Kyocera Scanner<EOL>To: bodemann@e.de<EOL>Mime-Version: 1.0<EOL>Content-Type: multipart/mixed;<EOL> boundary=\"boundary Mon 08 Jan 2007 11:52:26 +0100 boundary\"<EOL>Content-Transfer-Encoding: 8bit<EOL>X-PEERIP: 192.168.192.27<EOL>X-UIDL: 81310508.01.200711:52:27
192.168.192.31:2443 Sent 08.01.2007 11:53:17: <EOL>
192.168.192.31:2443 Sent 08.01.2007 11:53:17: <EOL>--boundary Mon 08 Jan 2007 11:52:26 +0100 boundary<EOL>Content-Type: text/plain; charset=\"utf-8\"<EOL>Content-Transfer-Encoding: base64<EOL><EOL>LS0tLS0tLS0tLS0tLS0tLS0tLQ0KS3lvY2VyYSAoMTkyLjE2OC4xOTIuMjcp<EOL>DQo=<EOL><EOL>--boundary Mon 08 Jan 2007 11:52:26 +0100 boundary<EOL>Content-Type: application/pdf;<EOL> name=\"doc08012007115213.pdf\"<EOL>Content-Disposition: attachment;<EOL> filename=\"doc08012007115213.pdf\"<EOL>Content-Transfer-Encoding: base64<EOL><EOL>JVBERi0xLjIKJcjH0MRG<EOL>CjggMCBvYmoKPDwKL1R5cGUgL1hPYmplY3QKL1N1YnR5cGUgL0ltYWdlCi9OYW1l<EOL>IC9JbTAKL1dpZHRoIDI0ODAKL0hlaWdodCAzNTA3Ci9MZW5ndGggOSAwIFIKL0Jp<EOL>dHNQZXJDb21wb25lbnQgOAovQ29sb3JTcGFjZSAvRGV2aWNlR3JheQovRmlsdGVy<EOL>IC9EQ1REZWNvZGUKPj4Kc3RyZWFt<EOL>Cv/Y/+AAEEpGSUYAAQIBASwBLAAA<EOL>/8QAHwAAAQUBAQEBAQEAAAAAAAAAAAECAwQFBgcICQoL/8QAtRAAAgEDAwIEAwUF<EOL>BAQAAAF9AQIDAAQRBRIhMUEGE1FhByJxFDKBkaEII0Kx8BVS0cEkM2JyggkKFhcY<EOL>GRolJicoKSo0NTY3ODk6Q0RFRkdISUpTVFVWV1hZWmNkZWZnaGlqc3R1dnd4eXqD<EOL>hIWGh4iJipKTlJWWl5iZmqKj

...

l6ZSAxMAovUm9vdCAyIDAgUgovSW5mbyAzIDAgUgo+Pgpz<EOL>dGFydHhyZWYKNTkwNjM0CiUlRU9G<EOL>Cg==<EOL><EOL>--boundary Mon 08 Jan 2007 11:52:26 +0100 boundary--<EOL><EOL>
192.168.192.31:2443 Sent 08.01.2007 11:54:02: <EOL>.<EOL>
192.168.192.31:2443 Recv 08.01.2007 11:54:02: DELE 1<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:54:02: +OK message 1 deleted<EOL>
192.168.192.31:2443 Recv 08.01.2007 11:54:02: QUIT<EOL>
192.168.192.31:2443 Sent 08.01.2007 11:54:02: +OK Have a nice day<EOL>
192.168.192.31:2443 Stat Disconnected.
0.0.0.0:0 Stat Disconnected.


Ab jetzt die Große, deren Ãœbertragung nicht funktioniert:


192.168.192.31:2975 Stat Connected.
192.168.192.31:2975 Sent 08.01.2007 12:07:59: +OK Welcome to LANMailServer 1.20 POP3 Server<EOL>
192.168.192.31:2975 Recv 08.01.2007 12:07:59: USER bodemann<EOL>
192.168.192.31:2975 Sent 08.01.2007 12:07:59: +OK Password required<EOL>
192.168.192.31:2975 Recv 08.01.2007 12:07:59: PASS pwd<EOL>
192.168.192.31:2975 Sent 08.01.2007 12:07:59: +OK Login OK<EOL>
192.168.192.31:2975 Recv 08.01.2007 12:07:59: STAT<EOL>
192.168.192.31:2975 Sent 08.01.2007 12:07:59: +OK 1 4821667<EOL>
192.168.192.31:2975 Recv 08.01.2007 12:07:59: LIST<EOL>
192.168.192.31:2975 Sent 08.01.2007 12:07:59: +OK 1 messages (4821667 octets)<EOL>
192.168.192.31:2975 Sent 08.01.2007 12:07:59: 1 4821667<EOL>
192.168.192.31:2975 Sent 08.01.2007 12:07:59: .<EOL>
192.168.192.31:2975 Recv 08.01.2007 12:07:59: RETR 1<EOL>
192.168.192.31:2975 Sent 08.01.2007 12:07:59: +OK 4821667 octets)<EOL>
192.168.192.31:2975 Sent 08.01.2007 12:07:59: Received: from Kyocera[192.168.192.27] (helo=Kyocera) by blaupause[192.168.192.50] with esmtp (LANMailServer 1.20)<EOL>Date: Mon 08 Jan 2007 11:59:24 +0100<EOL>From: kyocera@e.de<EOL>Subject: Kyocera Scanner<EOL>To: bodemann@e.de<EOL>Mime-Version: 1.0<EOL>Content-Type: multipart/mixed;<EOL> boundary=\"boundary Mon 08 Jan 2007 11:59:24 +0100 boundary\"<EOL>Content-Transfer-Encoding: 8bit<EOL>X-PEERIP: 192.168.192.27<EOL>X-UIDL: 482122708.01.200712:00:28
192.168.192.31:2975 Sent 08.01.2007 12:07:59: <EOL>

Outlook Express zeigt jetzt die Fehlermeldung, der Server hätte 60 sec. lang nicht reagiert. An der Auslastung des Rechners sollte das nicht liegen. Intel Core 2, 6600 @ 2.4 GHz, 3 GB RAM, Festplatte: WD 1500 ADFD 10.000 RPM.

Die abzuholende Email befindet sich immer noch im LocalMail Verzeichnis.

Gruß, Jörn



Admin E-Mail-Adressen entfernt.
Zuletzt geändert von Bodemann am 08.01.2007, 14:40, insgesamt 1-mal geändert.

Benutzeravatar
mirko
Beiträge: 21001
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 08.01.2007, 10:51

unter Konfiguration - Einstellungen Allgemein ganz unten die Logdatei aktivieren. Die wird dann zwar sehr groß aber man sieht dann an welcher Stelle es hängt.

Der Speicherverbrauch muss hoch gehen, da LANMailServer die Mail in den Speicher holt und danach an den Client, hier Thunderbird, weitergibt. Bleibt der Speicherverbrauch hoch und die Verbindung bestehen, dann ist es eindeutig so, dass Thunderbird die Verbindung noch nicht beendet hat und LANMailServer die Mail noch im Speicher hält. Günstig wäre vielleicht auch ein Abruf-Test mit Outlook Express oder Outlook. Vielleicht liegt es an der Thunderbird-Version, ich habe Version 1.5.0.9 (20061207) zur Zeit drauf.

Bodemann
Beiträge: 4
Registriert: 07.01.2007, 14:27

Beitragvon Bodemann » 08.01.2007, 10:33

Vielen Dank für das Nachschauen.

Ich habe sowohl den Virenscanner (NOD32) als auch die Firewall (Kerio) abgeschaltet, was aber keine Verbesserung bringt. Das hatte ich auch nicht erwartet, da es kein prinzipielles Problem der Email an sich zu sein scheint. Wenn ich nur eine Seite scanne, und damit der Anhang klein ist, gibt es kein Problem. Das Problem tritt erst ab einer gewissen Größe auf.

Folgendes Verhalten ist zu beobachten:

- Im Ruhezustand \"nimmt\" sich LanMailServer etwas 8.000 k Speicher. Sobald ich versuche, die Email abzuholen, geht der Speicherbedarf etwas auf 40.000 k hoch und pendelt dann stabil zw. ca. 37.000 und ca. 40.000 hin und her

- Die Ressourcen einer kompletten CPU werden allokiert (ich habe einen Intel Dual Core)

- Obwohl Thunderbird längst einen Timeout gemeldet hat, wird die Verbindung immer noch als \"bestehend\" angezeigt. 192.168.192.50pop3 Verbunden mit POP3 Server ... empfängt E-Mail

- Unter E-Mails in lokalen E-Mail-Konten erscheint der Username nicht mehr, was aber das gewünscht Verhalten während des Email abholens zu sein scheint

- Die letzte Zeile im Log-File: 08.01.2007 10:14:02 - Zugriff auf den POP3-Server durch: 192.168.192.50. Es scheint, als bekäme LanMailServer den Timeout nicht mit.

- Der LanMailServer läst sich nicht mehr zuverlässig beenden. Das klappt zwar manchmal, aber meistens muss man den Prozess \"abschießen\".

Ich kann das Problem auch provozieren, indem ich die gleiche Email, die ich Ihnen gestern Abend zugesandt haben, an einen zweiten Rechner im Lan sende. Das Senden klappt dann einwandfrei, das Abholen durch den zweiten Rechner zeigt dann das gleiche Problem.

Gruß, Jörn

Benutzeravatar
mirko
Beiträge: 21001
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 07.01.2007, 22:54

gut die Mail ist angekommen und konnte ich abrufen, die enthaltende .lock Datei konnte ich auch verwenden und die Mail mit der PDF mit Thunderbird problemlos abrufen. Ich sehe da irgendwie kein Problem, vielleicht macht ein Virenscanner Mist?

Benutzeravatar
mirko
Beiträge: 21001
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 07.01.2007, 21:03

ich hatte es erst mit großen Anhängen ausprobiert, gibt absolut kein Problem. Jetzt gerade nochmal mit Thunderbird probiert, läuft auch alles super. Kann natürlich sein, dass es an bestimmten Dateien oder an bestimmten Codierungen liegt. Das beste ist mir so eine PDF-Datei mal schicken. Per privater Message schicke ich dir eine E-Mail-Adresse, dann landet die Mail direkt im LANMailServer.

Bodemann
Beiträge: 4
Registriert: 07.01.2007, 14:27

Beitragvon Bodemann » 07.01.2007, 14:56

Ich betreibe einen LanMailServer (5 User Lizenz) 1.20.0.0105 auf WinXP SP2. Lokale Emails werden über eine Scan-Drucker- Kombination (Kyocera FS-1118MFP) als PDFs eingestellt. Diese Emails versuche ich mit eine Thunderbird (1.5.0.9) abzuholen. Dabei ergibt sich folgendes Verhalten:

1. Die Emails werden korrekt versandt und befinden sich in der Lokal-Mail-Queue des Adressaten. Die Änhänge sind zw. 2 MB und 12 MB groß.

2. Wenn ich die Email mit dem Thunderbird abhole, gibt es nach einiger Zeit einen Timeout. Darauf hin habe ich den Timeout Wert für POP3 im LanMailServer auf 240 sec hochgesetzt, was keine Änderung brachte.

3. Dann habe ich im Thunderbird eine Option eingeschaltet, die nur den Header einer Email lädt (Konten | Server-Einstellungen | Nur die Kopfzeilen herunterladen).

Jetzt lädt Thunderbird allerdings nicht nur die Kopfzeile, sondern auch noch die ersten beiden Zeilen aus dem Body. Danach kommt eine (vermutlich von Thunderbird erzeugte Meldung):

Gekürzt!
Diese Nachricht überschreitet die maximale Nachrichtengröße, die in den Einstellungen angegeben wurde, daher wurden nur die ersten Zeilen vom Mail-Server heruntergeladen. Klicken Sie hier, um die ganze Nachricht vom Server herunterzuladen.

\"Hier\" ist dann ein Link. Wenn man diesen Link klickt, führ das nach kurzer Zeit ebenfalls zu einem Timeout.

Interessanterweise enthält diese Email das Attachment per PDF. Ich dachte zunächst, es würde sich nur um einen Hinweise darauf handeln, dass noch ein Attachment vorhanden ist. Das Attachment lässt sich allerdings einwandfrei öffnen.

Die Email befindet sich danach immer noch in der lokalen Ausgangs-Queue des LanMailServer, was auch korrekt erscheint, da die Email noch nicht komplett abgeholt wurde.

Zusammengefasst heißt das: Ich kann die Email nicht komplett abholen, allerdings wird mir in der \"Nur Kopfzeilenversion\" das Attachment mit angehängt.

4. Das Problem tritt erst ab einer bestimmten Anhanggröße auf. Wenn ich nur eine Seite scanne, erscheint in der LanMailServer-Queue eine Email mit einem Attachment (ebenfalls PDF) von nur 48,2 KB Größe. Diese lässt sich ohne Probleme und komplett abholen und ist danach aus der Queue verschwunden.

Hat da evtl. jemand eine Idee?

Gruß, Jörn


Zurück zu „LANMailServer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron