LANMailserver hängt nach Neustart

Probleme, Tipps & Tricks zu LANMailServer

Moderator: mirko

elzag
Beiträge: 7
Registriert: 19.10.2012, 14:29

Re: LANMailserver hängt nach Neustart

Beitragvon elzag » 28.02.2017, 13:32

mirko hat geschrieben:Das Update laden, welches jetzt im Online-Update zu finden ist, danach muss Dienst und Programm komplett beendet werden bzw. Windows neu starten, danach wird er sich immer komplett neu starten, so als würde man manuell den Dienst beenden und wieder starten.

Prima, danke.
Habe das Update mal geladen und schaue wie sich der Server in den nächsten Tagen verhält.

Benutzeravatar
mirko
Beiträge: 20961
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Re: LANMailserver hängt nach Neustart

Beitragvon mirko » 27.02.2017, 13:58

Das Update laden, welches jetzt im Online-Update zu finden ist, danach muss Dienst und Programm komplett beendet werden bzw. Windows neu starten, danach wird er sich immer komplett neu starten, so als würde man manuell den Dienst beenden und wieder starten.

Benutzeravatar
mirko
Beiträge: 20961
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Re: LANMailserver hängt nach Neustart

Beitragvon mirko » 24.02.2017, 17:03

Er startet intern sich neu, d.h. der POP3- und SMTP-Server werden neu gestartet aber sich komplett neu starten kann er nicht, das kann man nur über eine externe Anwendung, Script oder über die Windows-Aufgabenplanung machen, dazu muss

Code: Alles auswählen

cmd /c "net stop "LMService" & sc start "LMService""


ausgeführt werden, nur dann wird komplett der Prozesse beendet und neu gestartet.

elzag
Beiträge: 7
Registriert: 19.10.2012, 14:29

Re: LANMailserver hängt nach Neustart

Beitragvon elzag » 24.02.2017, 16:17

Neu starten an sich ist nicht das Problem, das macht er jede Nacht.
Das Problem liegt daran das er nach dem Neustart oft (ca. 1-2 mal die Woche) seine Arbeit nicht verrichtet.
Und "nicht neu starten" möcht ich eigentlich auch nicht.

Ausser mit einem manuellen Test kann ich das ja nicht prüfen und im Fehlerfall automatisch nochmals neustarten.

Benutzeravatar
mirko
Beiträge: 20961
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Re: LANMailserver hängt nach Neustart

Beitragvon mirko » 06.12.2016, 11:39

Das kann man nicht irgendwie debuggen, bekommt man nichts bei einem Dienst raus. Über den Taskplaner/Aufgabenplanung z.B. jede Nacht den Dienst neu starten, das kann man über dieses Kommando machen:

Code: Alles auswählen

cmd /c "net stop "LMService" & sc start "LMService""

elzag
Beiträge: 7
Registriert: 19.10.2012, 14:29

LANMailserver hängt nach Neustart

Beitragvon elzag » 29.11.2016, 12:02

Hallo ,

wir verwenden den LANMailserver auf einem Windows Server 2008 R2 als Dienst.

Grundsätzlich klappt das eigentlich sehr gut.

Allerdings kommt es ungefähr einmal die Woche zu einem Hänger, heisst der LANMailserver reagiert nicht mehr.
In der Log-Datei ist der letzte Eintrag dann jeweils das neu starten der Dienste beim täglichen Neustart und dann einfach nichts mehr.

Sobald ich den Dienst neu gestartet habe, läuft dann alles wieder flott.
Ich schliesse daraus, das der LANMailserver vermutlich Probleme beim neu Starten der Dienste hat.
Gibt es eine Möglichkeit, einen Debug-Level mit mehr Infos für die Log-Datei zu aktiveren?

Oder kann ich dem Problem noch anders auf den Grund gehen?

Gruss, elzag


Zurück zu „LANMailServer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron