Socket Error 10053 - Lösungsvorschläge funktionieren leider

Fragen und Tipps & Tricks zur Newsletter Software SuperMailer oder zum BirthdayMailer

Moderatoren: mirko, Wolfi

Benutzeravatar
fraschi
Beiträge: 6
Registriert: 01.12.2007, 13:17

Beitragvon fraschi » 15.12.2007, 19:42

Wollte nur noch kurz zurückmelden, dass es tatsächlich wunderbar und wie vorgesehen funktioniert!

Danke für dein tolles und gut durchdachtes Program!

Ciao Franklin

Benutzeravatar
mirko
Beiträge: 20625
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 01.12.2007, 20:02

Original von Mirko:
Meine Empfehlung ist mittlerweile bei großen E-Mails, das sind meistens welche mit Anhang, die Versandvariante über Webspace/eigenen Server zu verwenden und die Option des einmaligen Uploads der Bilder/Anhänge zu aktivieren.


Ah, hier schreibst du \"Bilder/Anhänge\", obwohl du in deiner Hilfe dazu schreibst: \'Die integrierte Dateiupload-Funktion kann verwendet werden, um lokale Dateien in HTML-E-Mails vor dem E-Mail-Versand ins Internet zu übertragen. Diese Funktion ist nur für E-Mails im HTML-Format gedacht. Dateianhänge (Attachments) werden nicht ins Internet übertragen.\'
Was stimmt denn nun? Lässt sich dieser Weg auch für Datei-Anhänge zu reinen Text-Mails verwenden? Denn genau um diese Konstellation geht\'s mir aber, dass ich zu reinen Text-Mails noch PDF-Dateianhänge hinzufügen möchte / muss.

[/quote]

Der Dateiupload ist nur für die Bilder in den HTML-E-Mails, die werden dann ins Internet übertragen und SuperMailer ändert in der HTML-E-Mail alle Aufrufe auf die eigetragene HTTP-URL.

Außerdem kann ich diese Versandvariante ja leider in der Shareware-Version gar nicht testen und muss mit diesen Versuchen solange warten, bis ich den Lizenzschlüssel bekommen habe .... :-( [na ja, dürfte ja vielleicht am Montag eintrudeln, nachdem das Geld heute raus ging ....]


Das klappt schon wenn man eigenen Webspace mit PHP hat.

Original von Mirko:
Die Vorteile dieser Variante liegen wirklich auf der Hand, einmal die Bilder/Anhänge per E-Mail rüberschaufeln, danach gibt SuperMailer nur noch den E-Mail-Text an das Script auf dem Server. Das Script setzt alles wieder ordentlich zusammen und schickt es weg. Das spart sehr sehr viel Zeit, auch wenn man angibt, dass immer nur 1 E-Mail versendet werden soll, weil halt der riesen Anhang nur einmal übertragen werden muss.


Hmm, einmal von mir lokal ins Internet. Aber von dort soll dann jeder Text-Mail auch gleich die PDF-Datei(en) mit angehangen werden, weil die Leute ja nach dem Mail-Empfang nicht immer weiter online sind und die Anhänge dann nicht einfach z.B. durch einen weiteren Mausklick downloaden können. Die müssen also immer gleich schon mit als Datei automatisch jeder Mail beigefügt und vom Empfänger gleich zusammen mit der Mail runtergeladen werden. Sofern das möglich ist, hört sich das ja tatsächlich gut an.

[/quote]

Keine Gedanken machen. :) Der Empfänger bekommt immer seine Text-E-Mail mit Anhang hinten dran, der merkt nicht das der Anhang nur einmal übertragen wurde. Und natürlich ist Anhang im Offline-Zustand ebenfalls durch Empfänger abrufbar.

Benutzeravatar
fraschi
Beiträge: 6
Registriert: 01.12.2007, 13:17

Beitragvon fraschi » 01.12.2007, 18:05

Original von Mirko:
Hallo Franklin,

SuperMailer macht immer die Anhangscodierung vor dem Aufbau der Verbindung zum Server. Das wird pro eingestellten Thread genau einmal gemacht und danach zwischengespeichert.


Ah ja, na dann passt meine Vermutung natürlich nicht ....

Original von Mirko:
Schuld an diesem Fehler sind wirklich Antiviren-Programme, Firewall-Software,


Na ja, gut, aber dann müssten andere Mail-Proggis mit großen Datei-Anhängen ja auch ähnliche Probleme haben. Und das kann ich hier auf der Kiste z.B. für Crosspoint, Vivian-Mail und Fox-Mail ganz klar ausschließen, die können jede Größe problemlos versenden.

Original von Mirko:
Meine Empfehlung ist mittlerweile bei großen E-Mails, das sind meistens welche mit Anhang, die Versandvariante über Webspace/eigenen Server zu verwenden und die Option des einmaligen Uploads der Bilder/Anhänge zu aktivieren.


Ah, hier schreibst du \"Bilder/Anhänge\", obwohl du in deiner Hilfe dazu schreibst: \'Die integrierte Dateiupload-Funktion kann verwendet werden, um lokale Dateien in HTML-E-Mails vor dem E-Mail-Versand ins Internet zu übertragen. Diese Funktion ist nur für E-Mails im HTML-Format gedacht. Dateianhänge (Attachments) werden nicht ins Internet übertragen.\'
Was stimmt denn nun? Lässt sich dieser Weg auch für Datei-Anhänge zu reinen Text-Mails verwenden? Denn genau um diese Konstellation geht\'s mir aber, dass ich zu reinen Text-Mails noch PDF-Dateianhänge hinzufügen möchte / muss.

Außerdem kann ich diese Versandvariante ja leider in der Shareware-Version gar nicht testen und muss mit diesen Versuchen solange warten, bis ich den Lizenzschlüssel bekommen habe .... :-( [na ja, dürfte ja vielleicht am Montag eintrudeln, nachdem das Geld heute raus ging ....]

Original von Mirko:
Die Vorteile dieser Variante liegen wirklich auf der Hand, einmal die Bilder/Anhänge per E-Mail rüberschaufeln, danach gibt SuperMailer nur noch den E-Mail-Text an das Script auf dem Server. Das Script setzt alles wieder ordentlich zusammen und schickt es weg. Das spart sehr sehr viel Zeit, auch wenn man angibt, dass immer nur 1 E-Mail versendet werden soll, weil halt der riesen Anhang nur einmal übertragen werden muss.


Hmm, einmal von mir lokal ins Internet. Aber von dort soll dann jeder Text-Mail auch gleich die PDF-Datei(en) mit angehangen werden, weil die Leute ja nach dem Mail-Empfang nicht immer weiter online sind und die Anhänge dann nicht einfach z.B. durch einen weiteren Mausklick downloaden können. Die müssen also immer gleich schon mit als Datei automatisch jeder Mail beigefügt und vom Empfänger gleich zusammen mit der Mail runtergeladen werden. Sofern das möglich ist, hört sich das ja tatsächlich gut an.

Franklin
Zuletzt geändert von fraschi am 01.12.2007, 18:06, insgesamt 1-mal geändert.

Benutzeravatar
mirko
Beiträge: 20625
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 01.12.2007, 15:02

Hallo Franklin,

SuperMailer macht immer die Anhangscodierung vor dem Aufbau der Verbindung zum Server. Das wird pro eingestellten Thread genau einmal gemacht und danach zwischengespeichert. Ausnahme unter Menü Extras - Optionen, Registerkarte Erweitert hat man das Zwischenspeichern von Bildern und Anhängen deaktiviert. In diesem Fall wird es jedesmal von neuen gemacht, entsprechend dauert es bei großen Anhängen oder eingebetteten Bildern auch länger und die CPU-Belastung geht hoch.

Schuld an diesem Fehler sind wirklich Antiviren-Programme, Firewall-Software, zu viele Versandthreads in SuperMailer eingestellt => Stau in der Leitung und Trennung der Verbindung durch den E-Mail-Server z.B. weil die Mail zu groß ist. Stellt man zu viele Threads ein, dann nutzt es auch nichts den Timeout nach oben zu drehen, weil halt der Server, so wie du richtig sagst, nach einer gewissen trafficlosen Zeit die Verbindung einfach trennt.

Meine Empfehlung ist mittlerweile bei großen E-Mails, das sind meistens welche mit Anhang, die Versandvariante über Webspace/eigenen Server zu verwenden und die Option des einmaligen Uploads der Bilder/Anhänge zu aktivieren. Die Vorteile dieser Variante liegen wirklich auf der Hand, einmal die Bilder/Anhänge per E-Mail rüberschaufeln, danach gibt SuperMailer nur noch den E-Mail-Text an das Script auf dem Server. Das Script setzt alles wieder ordentlich zusammen und schickt es weg. Das spart sehr sehr viel Zeit, auch wenn man angibt, dass immer nur 1 E-Mail versendet werden soll, weil halt der riesen Anhang nur einmal übertragen werden muss.

Benutzeravatar
fraschi
Beiträge: 6
Registriert: 01.12.2007, 13:17

Beitragvon fraschi » 01.12.2007, 13:49

Ich hatte jetzt nach erstmaligem Ausprobieren des SuperMailers (natürlich? ) auch besagte 10053-Fehlermeldung, und wie die anderen auch nur bei großen Dateien. Und auch trotz der Einstellung auf nur einen Thread mit 180 Sekunden Timeout. Und auch bei abgeschalteter Anhangsprüfung durch die AV-Software und ohne Firewall-Blockierung.

Wenn ich mir die jeweiligen Logs so anschaue, die von (nicht erfolgreichen) Sendungen mit großen Dateianhängen mit denen (erfolgreich versandter) Mails mit nicht so großen Dateianhängen vergleiche, insbesondere die Zeitangabe bei den Sent-Zeilen, ergibt sich für mich die Frage, ob du dieses Problem, Mirko, nicht einfach dadurch lösen könntest, dass du die Anhangskodierung einfach von der zeitlichen Reihenfolge her *VOR* den ersten Kontakt zum Server legst? Denn nach meiner Vermutung liegt es einfach daran, dass die Gegenseite (aufgrund von dort vorgegebenen und von dir / deinem Proggi nicht beeinflussbaren Timeouts) einfach nach einer gewissen trafficlosen Zeit den Port dicht macht. Wenn die Anhangskodierung schon vor dem ersten Serverkontakt erledigt wäre, könnte der Versand anschließend hintereinander ununterbrochen erfolgen. [Ich kenne übrigens andere Mail-Proggis, die dies in dieser Reihenfolge handhaben und bei denen daher vermutlich der Versand großer Dateien auch keinerlei Problem macht.]

Sehe ich hier irgendetwas falsch? Stimmt meine Vermutung evtl. nicht? Ich bin im übrigen auch gerne bereit, eine Testversion deines Programmes, bei der die Kodierung vor dem ersten Serverkontakt erfolgt, zu beta-testen.

MfG

Franklin

wortmax
Beiträge: 16
Registriert: 05.03.2007, 14:13

Beitragvon wortmax » 09.10.2007, 22:12

Blanker HTML-Code ist ja immer noch besser als gar nichts. Dann schicke ich das jetzt so raus und deklariere es im Nachinein als Versandfehler. Aber Dein Angebot, dass Du Dir die Projektdatei mal ansiehst, würde ich auch gern nutzen, weil gleich Anfang nächster Woche eine Aussendung für einen Kunden ansteht, bei dem das gleiche Problem auftritt. Ich melde mich per Mail.

Einstweilen vielen Dank,
Holger

Benutzeravatar
mirko
Beiträge: 20625
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 09.10.2007, 21:58

blanken HTML-Code natürlich.

Du müsstest mir nach deine Reise mal die Projektdatei herschicken, vielleicht sehe ich irgendwas \"gefährliches\" im HTML- oder Text-Teil z.B. besondere Sonderzeichen.

wortmax
Beiträge: 16
Registriert: 05.03.2007, 14:13

Beitragvon wortmax » 09.10.2007, 21:35

Original von Mirko:
dann kann es nur der Text-Teil sein, der irgendein Problem enthält. Oder schick es diesmal einfach nicht-multipart, vielleicht löst sich das Problem mit einer Textänderung das nächste Mal.





Das Problem hatte ich bei den vorherigen Mails auch. Die habe ich mit Ach und Krach aussenden können.

Wenn Dir jetzt auch die Ideen ausgehen, bleibt mir wohl keine andere Möglichkeit, als auf multipart zu verzichten, aber was bekommen dann die Empfänger angezeigt, die kein HTML lesen können/wollen?

Benutzeravatar
mirko
Beiträge: 20625
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 09.10.2007, 21:32

dann kann es nur der Text-Teil sein, der irgendein Problem enthält. Oder schick es diesmal einfach nicht-multipart, vielleicht löst sich das Problem mit einer Textänderung das nächste Mal.

wortmax
Beiträge: 16
Registriert: 05.03.2007, 14:13

Beitragvon wortmax » 09.10.2007, 21:28

Nein, ich habe es eben nochmal versucht, auch daran liegt es nicht, dann würde er ja auch nicht reibungslos senden, wenn ich nur die HTML-Version (also multipart off) verschicke.

Benutzeravatar
mirko
Beiträge: 20625
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 09.10.2007, 21:15

na dann kann nur irgendein Sonderzeichen drin sein, dass Probleme macht.

Folgendes probieren:

Im SuperMailer rechte Maustaste in den Editor und Quelltext wählen.

Alles markieren und kopieren. Editor(Notepad) nehmen und einfügen, wieder im Editor rauskopieren und in ds SuperMailer-Quelltext-Fenster einfügen.

wortmax
Beiträge: 16
Registriert: 05.03.2007, 14:13

Beitragvon wortmax » 09.10.2007, 21:01

Threads steht bei 1, Timeout bei 120.

Benutzeravatar
mirko
Beiträge: 20625
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 09.10.2007, 20:59

Unter Menü Projekt - Einstellungen für den E-Mail-Versand die Anzahl Threads verringern, sind vielleicht zu viele eingestellt.

wortmax
Beiträge: 16
Registriert: 05.03.2007, 14:13

Beitragvon wortmax » 09.10.2007, 20:56

Sobald ich multipart deaktiviere, läuft es gut und die Mails im HTML-Format werden versendet. Kann es irgendwie mit der Textmail zu tun haben? Habe den Text auch schon über einen simplen Texteditor kopiert, um sicher zu gehen, nicht irgendwelche unsichtbaren Zeichen in den Text zu schleppen (ein solches Problem kenne ich von einem CMS). Aber daran liegt es auch nicht.

Textlänge habe ich vielleicht noch gedacht. Es sind zwar keine kurzen Mails, aber so übermäßig lang sind sie nun auch wieder nicht, vielleicht einanderthalb DIN A4 Seiten.

wortmax
Beiträge: 16
Registriert: 05.03.2007, 14:13

Beitragvon wortmax » 09.10.2007, 20:50

Mit dem AVK-Kram hatte Petrocelli das Probelm wohl lösen können.

Ich habe das nicht, sondern Antivir Personal Edition Classic, da habe ich keine Einstellungsmöglichkeiten für den Mailausgang, zumindest nicht, dass ich wüsste. Hatte das Programm aber schon deinstalliert, um zu testen, ob es am Antivirenprogramm liegt. Fehlanzeige. Selbst die Firewall habe ich abgeschaltet und auch alles übrige befolgt, was hier schon vorgeschlagen wurde.
Zuletzt geändert von wortmax am 09.10.2007, 20:51, insgesamt 1-mal geändert.


Zurück zu „SuperMailer, Newsletter Software und BirthdayMailer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste