"Weiße Seite" beim Upload-Manager

PHP Newsletter Software/Script und E-Mail-Marketing Software SuperWebMailer

Moderator: mirko

Benutzeravatar
mirko
Beiträge: 20979
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Re: "Weiße Seite" beim Upload-Manager

Beitragvon mirko » 23.11.2012, 13:18

Nein mit den Sessions hat das nichts zu tun. Bei den Sessions ist nur immer der http://-Aufruf wichtig, damit der Server den Browser wiedererkennt, ansonsten wird dien Session nicht mehr erkannt, dann fehlen die Login-Daten und damit blockt sofort der Filemanager, damit keiner von außen auf den Filemanager zugreifen kann.

lippoliv
Beiträge: 12
Registriert: 11.03.2012, 17:50

Re: "Weiße Seite" beim Upload-Manager

Beitragvon lippoliv » 23.11.2012, 12:34

Hey Mirko,
also ich bin die config_paths.inc.php durchgegangen.

Code: Alles auswählen

<?php
   /*
    Paths Configuration
   */

  # all Paths WITH slash /
   define('BasePath', '/'); # e.g. /swm/
   define('WebsiteURL', 'http://2.1.de/'); # e.g. http://superwebmailer.de/
   define('ScriptBaseURL', 'http://2.1.de/'); # e.g. http://superwebmailer.de/swm/
   define('InstallPath', '/var/www/vhosts/1/httpdocs/de_x_y/'); # e.g. /root/www/vhosts/superwebmailer.de/htdocs/swm/

  # DefaultPath for template files and sql folder if they are in another path with /
   define('DefaultPath', '');

   // Templates path name without / the subdirs must include the languages
   define('TemplatesPath', 'templates');
?>


Schaut soweit OK aus.

Dann ist mir aufgefallen, dass die config.inc.php, die config_db.inc.php und die config_paths.inc.php dem Benutzer 444.psaserv zugewiesen waren, mit den Rechten 755... Eigenartig da hatte ich mich wohl beim Setup vertippt und nicht "chmod 444" sondern "chown 444" eingegeben ^^
Ich habe den korrekten User eingetragen, dann erschient beim Aufruf von http://2.1.de/ oben der Hinweis auf falsche Dateirechte, ich habe die drei Scripts auf die Dateirechte 444 gesetzt und jetzt ist der Hinweis wieder weg.

Kann dass mit den Sessions auch daran gelegen haben?

Benutzeravatar
mirko
Beiträge: 20979
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Re: "Weiße Seite" beim Upload-Manager

Beitragvon mirko » 20.11.2012, 11:14

Die Session ist abgelaufen, meistens liegt es daran, dass der Aufruf der SWM-Installation über eine andere Domain erfolgte als in der config_paths.inc.php hinterlegt ist z.B. Installation in Unterverzeichnis aber Aufruf über Subdomain oder ganz anderen Domainnamen.

lippoliv
Beiträge: 12
Registriert: 11.03.2012, 17:50

"Weiße Seite" beim Upload-Manager

Beitragvon lippoliv » 20.11.2012, 10:09

Hallo,
für eine bekannte hoste ich eine SuperWebMailer-Instanz.

Sie hat einen Mac mit Safari und FireFox (alles aktuellste Version).

Beim Aufruf des Upload-Manager zum einfügen eines Bildes bleibt dieser aber "leer".

Im Anhang erklärende Screenshots, es scheint ein JS-Fehler vorzuliegen, die Error-Logs des Apache bleiben -soweit erkennbar- leer


Irgendwelche Ideen / Workarounds / Lösungen?
Dateianhänge
Bildschirmfoto2.jpg
FireBug-Ausgabe
Bildschirmfoto2.jpg (46.62 KiB) 564 mal betrachtet
Bildschirmfoto.jpg
"Leerer" Upload-Manager
Bildschirmfoto.jpg (37.05 KiB) 564 mal betrachtet


Zurück zu „SuperWebMailer, PHP Newsletter Software/Script“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste