Einfache Integration des FUM in ein xtcommerce web-shop

Fragen und Tipps & Tricks zum FollowUpMailer

Moderator: mirko

Benutzeravatar
mirko
Beiträge: 20978
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 03.08.2009, 11:03

Bei \"subscribe\" und \"unsubscribe\" muss man aufpassen, denn \"subscribe\" kommt natürlich in \"unsubscribe\" vor. Aus diesem Grund muss beim jeweiligen Responder bei \"Anmeldung\" oder \"Abmeldung\" immer als Bedingung definiert werden Wort \"subscribe\" bzw. \"unsubscribe\" bei der Abmeldung muss im Betreff vorkommen und zwar allein in der Zeile. Und genau diese Option hast du deaktiviert, ansonsten würde er nicht ausgeben \"hat sich versucht ein zweites Mal für den Respondern anzumelden, die E-Mail wurde ignoriert.\".


Die $SubscribeOKPage wird angezeigt aber nur wenn eine Anmeldung erfolgte (Action == \"subscribe\"). Man darf natürlich nicht beim HTML-Formularfeld Action, das value=\"subscribe\" in z.B. value\"anmelden\" ändern, dann funktioniert es nicht mehr.

Krystian
Beiträge: 2
Registriert: 02.08.2009, 12:59

Beitragvon Krystian » 03.08.2009, 09:51

Vielen dank, jetzt läufts.

Mal was anderes:

Ich möchte auf etwas hinweisen. Die Abmelde-email vom Webformular
ist vordefiniert mit dem Betreff \"unsubscribe\". Beim testen der Abmeldung
(alle Einstellungen habe ich berücksichtigt - > nur mit bestimmten Worten
Abmelden) kam folgende Meldung:

Portokol:

AUTORES MIT SCRIPT: Prüfe Postfach...
03.08.2009 06:15:55 - AUTORES MIT SCRIPT: Postfachprüfung abgeschlossen; 1 Nachrichten abgerufen.
03.08.2009 06:15:55 - AUTORES MIT SCRIPT: Prüfe E-Mail mit Betreff \"unsubscribe\".
03.08.2009 06:15:55 - AUTORES MIT SCRIPT: hat sich versucht ein zweites Mal für den Respondern anzumelden, die E-Mail wurde ignoriert.
03.08.2009 06:15:55 - AUTORES MIT SCRIPT: Die E-Mail löste keine Aktion aus.
03.08.2009 06:15:55 - AUTORES MIT SCRIPT: Die E-Mail wird zum Löschen vorgesehen.
03.08.2009 06:15:55 - AUTORES MIT SCRIPT: Lösche 1 bearbeitete E-Mails...
03.08.2009 06:15:56 - AUTORES MIT SCRIPT: Abgeschlossen.
03.08.2009 06:15:56 - AUTORES MIT SCRIPT: Prüfe ob Follow-Up-Nachrichten versendet werden müssen...
03.08.2009 06:15:56 - AUTORES MIT SCRIPT: An 0 Empfänger müssen Nachrichten versendet werden.
03.08.2009 06:15:56 - AUTORES MIT SCRIPT: Prüfung auf anstehende Follow-Up-Nachrichten beendet.
03.08.2009 06:15:56 - Bearbeitung von AUTORES MIT SCRIPT wurde beendet.


Im html-Code des Webformular, habe ich \"unsubscribe\" mit \"ABMELDEN\"
ersetzt und jetzt führt der Fum alles richtig aus.
----------------------------------------------------------------------------------

Ausserdem: die $OKPage erscheint nicht nach erfolgreicher Anmeldung, stattdessen erscheint die für die Abmeldung, und zwar in beiden Fällen.

Kann sein, dass ich irgendwo Fehler gemacht habe, aber bis jetzt habe ich keine gefunden.

MfG: Krys
Zuletzt geändert von Krystian am 03.08.2009, 11:04, insgesamt 1-mal geändert.

Benutzeravatar
mirko
Beiträge: 20978
Registriert: 25.11.2001, 15:14
Kontaktdaten:

Beitragvon mirko » 02.08.2009, 20:25

für die Eingabefelder (E-Mail usw.) ist ein HTML-Formular hinterlegt, in dem Formular oben steht z.B. drin <form>. Sie action= Angabe auf das korrekte Verzeichnis anpassen z.B. /shop/media/content/fum.php. Wichtig ist die 1. Angabe des /, damit von \"oben\" gesucht wird.

Krystian
Beiträge: 2
Registriert: 02.08.2009, 12:59

Beitragvon Krystian » 02.08.2009, 13:59

Hallo zusammen,

Ich bin ein stolzer Besitzer des FUM-Professional :d_zwinker:

Ich habe mir ausgedacht, den ordnungsgemäß erstellten
script fum.php, zusammen mit den 3 html-Seiten, via FTP in den
\"content-ordner\" des shops zu packen.

Der \"content-ordner\" (auf dem Server) ist dazu da, um html-Seiten
im Shop erscheinen zu lassen.

Allerdings ist der Pfad dann nicht nur: html/shop/fum.php , sondern html/shop/media/content/fum.php

Wenn ich die html-Seite (bereits im shop) aufrufe, erscheint dann
wie gewünscht die html-Seite mit den Eingabefeldern (E-mail,Name usw.)

Dann habe ich meine e-mail und einen Namen zu Testzwecken
eingetackert und auf senden gepusht. Folgendes bekam ich dann
zu sehen: Not found - The requested URL /shop/fum.php was not found on this server.

Wenn ich es richtig verstehe, müsste in diesem Fall der Pfad wie
schon oben angegeben sein. Was ist jetzt genau dafür zuständig?
das script fum.php? oder interne Pfadleitung des Shops?

Wäre schön wenn mir jemand helfen könnte. MfG: Krys


Zurück zu „FollowUpMailer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron